Android ICS-Tastatur im Browser ohne Wortvorschläge/Autokorrektur

Seit dem ich am 30.11. das neue Android-Flagschiff besitze, bin ich bis jetzt wirklich sehr zufrieden mit dem Gerät. Es ist schnell, hat einen tollen großen Bildschirm und es macht irre Spaß mit den Gerät Dinge zu tun, die man früher vielleicht nur am “großen” PC gemacht hätte.

Doch so langsam fallen mir hin und wieder Kleinigkeiten bei Android Ice Cream Sandwich 4.0.1 auf, die eher von unschönerer Natur sind. Aber in diesen Beitrag geht es zunächst nur um einen: Während man in allen von mir verwendeten Android-Apps, in denen man die Tastatur zum Schreiben verwenden kann, diese wunderbare Autokorrektur und Wortvervollständigung der überarbeiteten Android ICS-Tastatur benutzen kann (zu sehen im nachfolgenden Bild), fehlt von dieser im hauseigenen Android-Browser jeden Spur (siehe 2. Bild).

androidKeyboardApps

androidKeyboardBrowser

Das ganze empfinde ich als äußerst unschön, da ich ja auch hin und wieder auf anderen Blogs Kommentare per Samsung Galaxy Nexus ablassen möchte. Ich muss nun je nach Anwendungsfall ein anderes Schreibverhalten auf dem Gerät an den Tag legen. Beispiel: Um Satztrennzeichen einzufügen betätige ich zunächst nach jeden geschriebenen Wort zunächst die Leertaste. Anschließend bekomme ich in der Autokorrekturzeile der virtuellen Tastatur die häufigsten Satztrennzeichen angeboten. Ein kurzes Tippen auf eines der Symbole lässt das zuletzt angefügte Leerzeichen verschwinden und ersetzt dieses durch das ausgewählte Symbol. Obendrein erscheint danach auch nach den Trennzeichen sofort wieder ein Leerzeichen.

Zusammenfassung:

  • ich schreibe Test_ (_ =: Leerzeichen)
  • tippe auf das angebotene =,=
  • es erscheint Test,_

Das war jetzt nur ein Beispiel wo ich diese Korrekturzeile der Tastatur schmerzlich vermisse. Für mich ist dieser Umstand deshalb ein klarer BUG und kein Feature! Ich hoffe, dass Google hier demnächst nachbessert und zumindest eine Option in den Einstellungen der ansonsten doch sehr gelungenen ICS-Tastatur anbietet. Wie kommt ihr mit diesen Verhalten klar?

Update 2011-12-17 Sat:

Ganz so krass verhält es sich scheinbar doch nicht. Zumindest gibt es Seiten, auf denen die Autokorrektur funktioniert. Teilweise ist es sogar so, dass bei einigen Kommenatarbox bei der Eingabe der Email-Adresse die diese obere Zeile erscheint, in der eigentlichen Kommentarbox jedoch wieder verschwindet. Für mich sieht es momentan so aus, als ob manche Formularfelder fälschlicherweise als Passwortfeld identifiziert werden. In einen solchen Feld erscheint die Autokorrektur nämlich ebenfalls nicht und hier würde dieses Verhalten für mich auch Sinn machen.

Update 2011-12-18 Sun:

Es gibt jetzt auch einen Bug-Report. Bitte unterstützt diesen indem ihr einen Stern dafür abgebt!